Logo de ce site

Accueil > SPIP - aides, conseils et tutoriaux pas à pas > Installation de SPIP sur OVH

Installation de SPIP sur OVH

lundi 10 janvier 2011

Pour information, l’installation à l’aide du fichier spip_loader.php n’a pas fonctionné ; rien est perdu puisque la solution se trouve chez OVH...

OVH intègre la possibilité d’installer en quelques clics un certain nombre de modules dont fait partie SPIP.

A partir de votre Manager, vous pouvez demander l’installation du module SPIP ; les petites mains de chez OVH se chargerons de l’installation des fichiers...

1. Connectez-vous à votre Manager, accédez à la partie Hébergement puis cliquez sur Service Web - dans la partie centrale de la page -

2. Cliquez sur Ajouter un module

3. Cliquez sur SPIP - vous notez que la version proposée est la 2.0.10

4. Renseignez ici le chemin d’installation du futur site SPIP ; vous pouvez aussi installer SPIP à la racine de votre site en supprimant le contenu du champ de saisie et enregistrer.

5. La demande est en cours de traitement... vous allez recevoir un mail de confirmation...

6.

7.

8.


Maintenant, je viens de réaliser que j’ai travaillé sur un projet de site en local avec une version plus récente de SPIP. J’ai donc contacté l’assistance de chez OVH qui m’a répondu d’installer manuellement mes fichiers SPIP. Je me lance dans cette nouvelle installation avec un nouvelle article en préparation.

Messages

  • Bonjour,
    Merci pour ce tutoriel simple et concis.
    Je suis exactement dans le même cas que vous, à savoir que j’ai déjà travaillé avec une version plus récente de SPIP en local.
    J’ai essayé plusieurs fois de faire la mise à jour, manuellement et avec spip_loader, hélas, au mieux je me retrouve avec une erreur 302.
    Avez-vous réussi de votre côté ? Je crois comprendre que vous êtes actuellement en version 2.1.6 ? (d’ailleurs, à ce propos, spip vient de corriger une faille de sécurité apparemment très importante, ils recommandent d’installer la nouvelle version 2.1.8)

  • Bonjour et merci pour votre message...

    En effet, je suis sous spip 2.1.6 et vais passer d’ici peu sous 2.1.8 d’ici peu.... ce soir je crois.

    Pour répondre à votre question, oui j’ai réussi l’installation manuel des fichiers SPIP - le tuto est en cours de rédaction - ainsi que l’installation de ma base (version locale) à partir du fichier de sauvegarde sur mon serveur distant...

  • La mise à jour vers SPIP 2.1.9 avec spip_loader.php se passe sans aucune difficulté !
    A ma grande surprise, la mise à jour se fait très très rapidement !!!

    J’ai tout de même eu un message d’erreur à l’affichage de la page spip_loader.php que voici :

    Fatal error : Cannot redeclare _tt() (previously declared in /homez.316/steadiri/www/spip_loader.php:103) in /homez.316/steadiri/www/spip_loader.php on line 894

    J’ai tout de même lancer la mise à jour qui c’est passé sans souci !!!